7点测试论坛's Archiver

此论坛为旧版论坛,访问新论坛,请点击:www.7dtest.com.

xn_selena 发表于 2010-1-25 16:04

Loadrunner中生成结果时遇到的问题

我用的是HP Loadrunner 9.0 ,在controller中压完后,自动生成结果,但是生成结果的过程中,提示了一个错误,无法生成graph,内容如下:
The following graph(s) were not created:
1. Hit per second
2. Throughput
3. Transaction Summary
4. Average Transaction Response Time
Possible reason:
The graph, as defined, results in no data.

还有个Analysis Error log,请各位帮忙看看。
log文件中很多都是not found,摘要一段如下:
Analysis Error log: <2010-1-25 15:04:43>
75003 Transaction : <vuser_init_Transaction> InstanceID: 8589934593. Vuser not found
Data Point : <HTTP_302>. Vuser:10 Group: 05 not found
Data Point : <HTTP_404>. Vuser:10 Group: 05 not found
75003 Transaction : <vuser_init_Transaction> InstanceID: 4294967297. Vuser not found
Data Point : <HTTP_404>. Vuser:10 Group: 05 not found
Data Point : <HTTP_404>. Vuser:10 Group: 05 not found
75003 Transaction : <Action_Transaction> InstanceID: 8589934594. Vuser not found
Data Point : <HTTP_200>. Vuser:10 Group: 05 not found
Data Point : <tcp_connection_count>. Vuser:10 Group: 05 not found
Data Point : <tcp_connect>. Vuser:10 Group: 05 not found
Data Point : <tcp_shutdown>. Vuser:10 Group: 05 not found
Data Point : <HTTP_302>. Vuser:10 Group: 05 not found
Data Point : <HTTP_404>. Vuser:10 Group: 05 not found
Data Point : <HTTP_302>. Vuser:2 Group: 05 not found
75003 Transaction : <[url]http://10.8.101.106:8682/lndm/login.do?method=login[/url]> InstanceID: 4294967300. Vuser not found
75003 Transaction : <[url]http://10.8.101.106:8682/lndm/portal.jsp[/url];jsessionid=ED7D8F9136CD837B3DDD3B6E0B9AB6FB> InstanceID: 4294967302. Vuser not found
75003 Transaction : <[url]http://10.8.101.106:8682/lndm/ui/css/widgets.css[/url]> InstanceID: 4294967304. Vuser not found
75003 Transaction : <[url]http://10.8.101.106:8682/lndm/ui/css/layout.css[/url]> InstanceID: 4294967303. Vuser not found
75003 Transaction : <[url]http://10.8.101.106:8682/lndm/ui/css/theme.css[/url]> InstanceID: 4294967305. Vuser not found
Data Point : <HTTP_404>. Vuser:2 Group: 05 not found
.......

milan 发表于 2010-1-25 16:27

The following graph(s) were not created:
1. Hit per second
2. Throughput
3. Transaction Summary
4. Average Transaction Response Time
这些图是analysis的基本内容。可能安装有问题,重新安装下LR,再试试。

xn_selena 发表于 2010-1-25 16:36

我是新装的9.0,之前还没有问题呢,今天突然就不行了,与什么设置有关吗?

milan 发表于 2010-1-25 16:45

[b] [url=http://bbs.7dtest.com/redirect.php?goto=findpost&pid=20937&ptid=3752]3#[/url] [i]xn_selena[/i] [/b]


以前也遇到过一次类似情况。也是LR9.0。我是analysis打不开。后来重装就OK了。所以我建议你重装试试。

pupu840323 发表于 2010-1-25 16:56

我也遇到过,我修复了一下LR就好了

xn_selena 发表于 2010-1-25 17:14

哈哈,终于找到原因啦,没有重装,是因为我的脚本名称用0(零)开头了,改为其他数字或字母,再运行,就ok了。

页: [1]

Powered by Discuz! Archiver 7.2  © 2001-2009 Comsenz Inc.